Welcome, Guest
Username: Password: Remember me

TOPIC: Showing images with depth overlays on an HDS

Showing images with depth overlays on an HDS 5 years 10 months ago #2162

  • Fishton
  • Fishton's Avatar
  • Offline
Thanks Matt, that was the ticket.

Much appreciated.
_________________
John Easton
www.fishtec.co.za
The administrator has disabled public write access.

Showing images with depth overlays on an HDS 5 years 10 months ago #2163

  • Matt
  • Matt's Avatar
  • Offline
Nice!
The automated export will help a bit (a lot, even), but I know there's plenty we can still do to make it more intuitive so don't be shy if you have some suggestions.

cheers,
Matt
The administrator has disabled public write access.

Showing images with depth overlays on an HDS 5 years 10 months ago #2164

  • Fishton
  • Fishton's Avatar
  • Offline
This will be a good thread for others that run into the same problem in the future.
_________________
John Easton
www.fishtec.co.za
The administrator has disabled public write access.

Showing images with depth overlays on an HDS 5 years 3 months ago #3876

  • fvignola
  • fvignola's Avatar
  • Offline
Matt, I tried to follow this procedure to combine my 3D Raster image with Vector Data from Reefmaster...

The Raster stay behind the Vector data... I view it when playing with the zoom, but just for a second... The Vector Data always displayed over the Raster...

I followed exactly your procedure, but it won't work...

BUT, there is one little thing... You said to make sure that "Export Raster Background" is unchecked... But when I export (Write to file) the User Map, I can't see that option ?????????? And after export, I have a ShadedRelief folder, so it look like the Raster Background was exported too... Where is that option ? I can't see it at all...

Thanks

Fred
The administrator has disabled public write access.

Showing images with depth overlays on an HDS 5 years 3 months ago #3878

  • Matt
  • Matt's Avatar
  • Offline
Hi Fred,
In the current version of ReefMaster, that option is not shown - the decision whether or not to export a raster background is taken automatically. A raster background if either 1. a project is exported in raster mode, in which case the depth colour raster is exported or 2. polygons with transparency are exported from a user map. In this case a "dummy" raster is exported (just a single colour rectangle), which is required for Lowrance units to be able to use transparency (this is just a Lowrance quirk; transparency for polygons only works if the polygons are rendered over a raster).

For you situation it actually doesn't matter. You have created your own raster background, so you don't need the raster background created by ReefMaster - you should ignore any output from RM in the ShadedRelief folder and just use the raster files that you generated with your own 3D image.

As for seeing your raster - vector is always shown over raster and there is nothing you can do to change this. If you want to see your raster through your map you have to either create semi-transparent isobaths (via a User Map) or use contour lines only. If you want to use contour lines only, either create a UM with only lines (and also shoreline) or (better) export a project in raster mode and use the resulting at5 files (but not the raster files). The reason that the second option might be better in your case is that you will get an inverted shoreline polygon, which will surround your lake and clip the edges of your raster, so you will lose the black border and get well defined shorelines.

Hope that all makes sense,
Matt
The administrator has disabled public write access.

Showing images with depth overlays on an HDS 5 years 3 months ago #3879

  • fvignola
  • fvignola's Avatar
  • Offline
Matt wrote:
For you situation it actually doesn't matter. You have created your own raster background, so you don't need the raster background created by ReefMaster - you should ignore any output from RM in the ShadedRelief folder and just use the raster files that you generated with your own 3D image.

As for seeing your raster - vector is always shown over raster and there is nothing you can do to change this. If you want to see your raster through your map you have to either create semi-transparent isobaths (via a User Map) or use contour lines only. If you want to use contour lines only, either create a UM with only lines (and also shoreline) or (better) export a project in raster mode and use the resulting at5 files (but not the raster files). The reason that the second option might be better in your case is that you will get an inverted shoreline polygon, which will surround your lake and clip the edges of your raster, so you will lose the black border and get well defined shorelines.

Hope that all makes sense,
Matt

It's what I've done... Only took the At5.xml and Large.at5 and ignored the shadedrelief folder...

And I tried semi-transparent map like you suggest... Like I told you, I followed exactly your procedure... But even with isoBath opacity set to 1 in the user map, that's not transparent at all and my 3d Raster stay hidden behind... Opacity closest to 1 only make the map paler, not transparent in any way ????
Last Edit: 5 years 3 months ago by fvignola.
The administrator has disabled public write access.

Showing images with depth overlays on an HDS 5 years 3 months ago #3880

  • Matt
  • Matt's Avatar
  • Offline
It sounds like you might have a filled shoreline between the isobaths and the raster.
Are you exporting from a user map directly, or running Shapefiles through the IMC?

By default in a UM there is a filled shoreline object which will be exported. If this is present (and not transparent) then this will block your isobaths. It is also what makes your isobaths look "paler", as they actually are becoming transparent but the white water body is showing through.

If you export directly from a project, you won't get a filled shoreline when exporting raster for exactly this reason.

If you are running the shapefiles through the IMC by hand, don't include the shoreline file, but do include the inverted shoreline.

If you are exporting from a UM, delete the shoreline or set it to full transparency. I think it would be better in your situation to export from a project or run the IMC yourself, as in this case you get the inverted shoreline (land with a hole for the water) that clips the edge of the raster.
The administrator has disabled public write access.

Showing images with depth overlays on an HDS 5 years 3 months ago #3881

  • fvignola
  • fvignola's Avatar
  • Offline
Haaaa, finally... Thanks you Matt...

Yes, I export directly from user map...

I just set the Shoreline opacity to 1, and it's now working great !!!

And the map look fantastic now...







Now I'll play with color and transparency to improve it... Hours of fun to come...


Great thanks Matt... ;)
The administrator has disabled public write access.

Showing images with depth overlays on an HDS 5 months 4 weeks ago #11204

  • MarsArtis
  • MarsArtis's Avatar
  • Offline
Any advice on 2.0 walk-through?

I'm not getting any "overlay" with EliteTi.
And after the latest maintenance update neither the mosaic is working as it should.

I'm Mapping for EliteTi
when manually exporting a map project with a mosaic layer I do select:
  • atlas v12
  • check depth highlight - isobaths
  • raster options type shaded relief / export raster layers / fill background colour DCDCDC / min res 1 max res 32.
with the above options i'm unable to:
  • - show the mosaic as SHADED RELIEF (it only shows by selecting in view/foto overlay FULL) but this way the raster quality is way to low.Further, in presentartion menu SHADED RELIEF is always on!
  • - depth shading as intentended with Social Map or the C-Map is not possible (completely greyed out). U'll say, ok just use the depth Higlight options. BUT it's showing me with a gap I've 0-1, 1-2 and than it jumps to 10-11 meters. Where have all the other depth gone?
The administrator has disabled public write access.

Showing images with depth overlays on an HDS 5 months 3 weeks ago #11205

  • Matt
  • Matt's Avatar
  • Offline
This shouldn't be a change due to the maintenance release, as nothing was changed in this area.
Can you provide more details (with screen shots) of the issues you are describing? Have you updated your Elite firmware recently? Which version of the IMC are you using?
The administrator has disabled public write access.

Showing images with depth overlays on an HDS 5 months 3 weeks ago #11208

  • MarsArtis
  • MarsArtis's Avatar
  • Offline
IMC 0.7.4.0
EliteTi5 to latest available fw version 18.2

I've made few tests:
using ATLAS v10 the shaded relief is working as expected on the device: chart options/presentation/shaded relief
if using ATLAS v12 or 13 the shaded relief function does not work and the mosaic (or overlayed bathy+mosaic) is available and viewable only via chart options/view/photo overlay/furll or land is the same
Last Edit: 5 months 3 weeks ago by MarsArtis.
The administrator has disabled public write access.

Showing images with depth overlays on an HDS 5 months 3 weeks ago #11214

  • gpiverson
  • gpiverson's Avatar
  • Offline
There's an imagery type in Advanced Options->Raster Options. You need to set that to Shaded Relief instead of Satellite Imagery if you want the Shaded Relief toggle to turn it off and on. Chart plotter default is Shaded Relief when no categorization can be stored in the format.
The administrator has disabled public write access.
SCROLL TO TOP

We use cookies to improve our website and your experience when using it. Cookies used for the essential operation of the site have already been set. To find out more about the cookies we use and how to delete them, see our Privacy Policy.

I accept cookies from this site